ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 37556] New: - property environment fail when use PATH on Windows XP
Date Fri, 18 Nov 2005 11:40:08 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=37556>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=37556

           Summary: property environment fail when use PATH on Windows XP
           Product: Ant
           Version: 1.6.5
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: major
          Priority: P2
         Component: Core tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: zomen@freemail.hu


On win XP ant does not resolve PATH environment variable.

The script:

<?xml version="1.0" encoding="ISO-8859-1"?>
<project name="TestEnv" basedir="." default="all">
    <target name="all">
        <property environment="shenv"/>
        <echo message="${shenv.PATH}"/>
        <echo message="${shenv.ANT_HOME}"/>
    </target>
</project>

The output:

Buildfile: build.xml

all:
     [echo] ${shenv.PATH}
     [echo] X:\devtools\apache-ant-1.6.5

BUILD SUCCESSFUL

When this script is running in a cygwin shell, then the result is OK.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message