ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 37546] New: - <javac> compilerarg doesn't support 'modern' compiler
Date Thu, 17 Nov 2005 09:15:42 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=37546>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=37546

           Summary: <javac> compilerarg doesn't support 'modern' compiler
           Product: Ant
           Version: 1.6.5
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Core tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: maarten.coene@hotpop.com


Hi,

I'm having problems with the compilerarg element in combination with 
the 'modern' compiler.

I have this added to my javac element:
<javac ...>
    <compilerarg line="-nowarn" compiler="modern" />
</javac>

If I run this in verbose mode, I get this on the console (using JDK1.4)

[javac] Using modern compiler
[javac] Compilation arguments:
[javac] '-d'
[javac] 'C:\test\build\classes'
[javac] '-classpath'
[javac] '...'
[javac] '-sourcepath'
[javac] 'C:\test\src'
[javac] '-g'
[javac]
[javac] The ' characters around the executable and arguments are
[javac] not part of the command.

As you can see, the '-nowarn' option is lost!

However, if I change the 'modern' compiler to 'javac1.4', it works:
<javac ...>
    <compilerarg line="-nowarn" compiler="javac1.4" />
</javac>

[javac] Using modern compiler
[javac] Compilation arguments:
[javac] '-d'
[javac] 'C:\test\build\classes'
[javac] '-classpath'
[javac] '...'
[javac] '-sourcepath'
[javac] 'C:\test\src'
[javac] '-g'
[javac] '-nowarn'
[javac]
[javac] The ' characters around the executable and arguments are
[javac] not part of the command.

Can you please fix this?

regards,
Maarten

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message