ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kev Jackson <kevin.jack...@it.fts-vn.com>
Subject Re: Quick question about properties
Date Thu, 13 Oct 2005 04:36:18 GMT
Stefan Bodewig wrote:

>On Thu, 13 Oct 2005, Kev Jackson <kevin.jackson@it.fts-vn.com> wrote:
>
>  
>
>>However if I try to run the project buildfile (./build.xml), none of
>>the properties are available (quick checks with echo just give me
>>variables instead of expanded properties).
>>    
>>
>
>This is not what I've seen in the past.  Properties declared in the
>imported build file just worked as expected.  Are you sure your
>property file is loaded at all?
>  
>
Yes the properties file is being loaded (just rechecked now).  It seems 
to be a problem if I reference a property from the common properties 
file within the project specific file.  Eg

./common/build.properties
...

lib.dir=lib
...

./project.properties
...
ant-contrib.version=1.0b1
ant-contrib.jar=${lib.dir}/commons-and-misc/ant-contrib-${ant-contrib.version}.jar
...

With the same build.xml files

./common/build.xml
...
<!-- global project properties -->
<property file="common/build.properties" />
...

./build.xml
...
<property file="local.properties" />
<import file="common/build.xml" />
...

The output from ./build.xml...

init:
     [echo] ${lib.dir}/commons-and-misc/ant-contrib-1.0b1.jar
     [echo] com.ftsvn
  [taskdef] Could not load definitions from resource 
net/sf/antcontrib/antcontri
b.properties. It could not be found.

I'll try to build a simple couple of test build files to demonstrate the 
behaviour in an independent way

Again sorry to bother anyone
Kev

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message