ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 35562] New: - sshexec corrupts output written to STDERR
Date Thu, 30 Jun 2005 14:06:53 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=35562>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=35562

           Summary: sshexec corrupts output written to STDERR
           Product: Ant
           Version: 1.6.5
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Optional Tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: rick.phillips@emergis.com


Running Ant 1.6.5 from binary distribution, with JAVA 1.3.1.06, JCE 1.2.2, and
jsch 0.1.20.

Output written to STDERR on remote machine is displayed on local machine
basically one word per line.  The scripts being run on the remote machine
include a "set -x" whose output is written to STDERR.  Prior to moving to 1.6.5,
I was using ant 1.5.4 and exec'ing the "ssh" command which worked fine, the
following is a sample of the output:

        ssh:
             [echo] server.host=arwen
             [echo] server.userid=proto2
             [echo] script=cd /usr/local/home/dropoff/deploy/proto2 && chmod 700
install-proto2-all_fulldata_tnwipe-sm.sh &&
./install-proto2-all_fulldata_tnwipe-sm.sh 'dbboss' 'proto2admin^'
             [exec] $Header:
/u01/projects/cvs/omega/build/scripts/deploy/install_sm.sh,v 1.37 2005/02/15
18:25:29 ssaksa Exp $
             [exec] + setup_logging scripts/install_sm.sh.log
             [exec] LOGFILE=scripts/install_sm.sh.log
             [exec] MAILTO=
             [exec] + [ ! -z scripts/install_sm.sh.log ]
             [exec] OPIPE=.27956.outpipe
             [exec] + [ ! -z  ]
             [exec] + has_tokens scripts/install_sm.sh
             [exec] + mkfifo .27956.outpipe
               .
               .
               .

After moving to Ant 1.6.5 and the "sshexec" task the output appears as follows:

        install-sm:
          [sshexec] Connecting to arwen:22
          [sshexec] $Header:
/u01/projects/cvs/omega/build/scripts/deploy/install_sm.sh,v 1.37 2005/02/15
18:25:29 ssaksa Exp $
          [sshexec] +
          [sshexec] setup_logging
          [sshexec]
          [sshexec] scripts/install_sm.sh.log
          [sshexec]
 
          [sshexec] LOGFILE=scripts/install_sm.sh.log
 
          [sshexec] MAILTO=
 
          [sshexec] +
          [sshexec] [
          [sshexec]
          [sshexec] !
         [sshexec]
          [sshexec] -z
          [sshexec]
          [sshexec] scripts/install_sm.sh.log
          [sshexec]
          [sshexec] ]
          [sshexec]
 
          [sshexec] OPIPE=.27057.outpipe
 
          [sshexec] +
          [sshexec] [
          [sshexec]
          [sshexec] !
          [sshexec]
          [sshexec] -z
          [sshexec]
          [sshexec]
          [sshexec] ]
          [sshexec]
 
          [sshexec] +
          [sshexec] mkfifo
          [sshexec]
          [sshexec] .27057.outpipe
          [sshexec]
              .
              .
              .

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message