ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 35215] New: - Ant.bat with all parameters in ANT_ARGS always exit code of 1
Date Fri, 03 Jun 2005 21:15:47 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=35215>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=35215

           Summary: Ant.bat with all parameters in ANT_ARGS always exit code
                    of 1
           Product: Ant
           Version: 1.7Alpha (nightly)
          Platform: PC
        OS/Version: Windows 2000
            Status: NEW
          Severity: normal
          Priority: P3
         Component: Wrapper scripts
        AssignedTo: dev@ant.apache.org
        ReportedBy: zwige01@ca.com


When calling ANT.BAT with all the parameters passed through ANT_ARGS and no
parameters on the ANT command line (eg: CALL ANT.BAT), ANT.BAT always set an
ERRORLEVEL of 1 even if the build succeeds. The source of the problem is "set
ANT_CMD_LINE_ARGS=" in ANT.BAT. It ANT_CMD_LINE_ARGS is not defined, which
happens if all the arguments are passed through ANT_ARGS, trying to undefined an
undefined environment variable sets ERRORLEVEL to 1. The solution is to set
ANT_CMD_LINE_ARGS to a dummy value before unsetting it. Eg: "set
ANT_CMD_LINE_ARGS=SetToDummyValueToAvoidErrorlevel1WhenUnset".

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message