ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 34936] - java.io.IOException: cvs: not found when calling ant from crontab
Date Tue, 17 May 2005 16:06:08 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=34936>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=34936





------- Additional Comments From alexeys@inventigo.com  2005-05-17 18:05 -------
> I found some information on the Internet 
> (http://www.aplawrence.com/Unixart/cron.html) that said you don't need to use 
> export so I created a script that set all the variables required and then 
> called the ant script but still no joy.

I think this is something else. Your script is executed with some interpreter 
and that interpreter does require "export". In any case, add plain "set" command
into your cron job script to see what environment is set and what is missing
(look for PATH, HOME, TMP, etc. environment variables). You may also need to
change the current directory before executing any commands.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message