ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 34774] New: - [ejbdeploy] Class "com.ibm.etools.ejbdeploy.plugin.EJBDeployPlugin" must not be on the classpath
Date Fri, 06 May 2005 09:32:15 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=34774>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=34774

           Summary: [ejbdeploy] Class
                    "com.ibm.etools.ejbdeploy.plugin.EJBDeployPlugin" must
                    not be on the classpath
           Product: Ant
           Version: 1.6.2
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: blocker
          Priority: P1
         Component: Build Process
        AssignedTo: dev@ant.apache.org
        ReportedBy: pratikl@quinnox.com
                CC: pratikl@quinnox.com


Following is an exerpt of my script



<path id="ejbdeploy.classpath">
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application Developer\v5.1\runtimes\base_v5\lib\deployutils.jar"/>
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application Developer\v5.1\runtimes\base_v5\lib\wsanttasks.jar"/>
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application Developer\v5.1\runtimes\base_v5
\java\jre\lib\ext\ibmorb.jar"/>
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application Developer\v5.1\bin\batch.jar"/>
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application Developer\v5.1
\wstools\eclipse\plugins\com.ibm.etools.ejbdeploy_5.1.0\runtime\codegen.jar"/>
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application Developer\v5.1
\wstools\eclipse\plugins\com.ibm.etools.ejbdeploy_5.1.0\runtime\ejbdeploy.jar"/>
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application Developer\v5.1
\wstools\eclipse\plugins\com.ibm.etools.ejbdeploy_5.1.0
\runtime\ejbincrement.jar"/>
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application Developer\v5.1
\wstools\eclipse\plugins\com.ibm.etools.ejbdeploy_5.1.0
\runtime\ejbvalidator.jar"/>
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application Developer\v5.1
\wstools\eclipse\plugins\com.ibm.etools.ejbdeploy_5.1.0\runtime\exec.jar"/>
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application Developer\v5.1
\wstools\eclipse\plugins\com.ibm.etools.ejbdeploy_5.1.0\runtime\rmic.jar"/>
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application Developer\v5.1\eclipse\plugins\org.eclipse.core.boot_2.1.1
\boot.jar"/>
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application 
		Developer\v5.1\runtimes\base_v5\lib\ivjejb35.jar"/>
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application 
		Developer\v5.1\runtimes\base_v5\lib\j2ee.jar"/>
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application 
		Developer\v5.1\runtimes\base_v5\lib\vaprt.jar"/>
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application 
		Developer\v5.1\runtimes\base_v5\lib\xerces.jar"/>
		<pathelement location="D:\Program Files\IBM\WebSphere 
Studio\Application Developer\v5.1\eclipse\plugins\org.eclipse.core.runtime_2.1.1
\runtime.jar"/>
		
	</path>


	

<target name="init">
<ejbjar
		srcdir="${ejbModule}"
		destdir="${srcDir}\strideEJB"
		descriptordir="strideEJB\ejbModule\META-INF"
		
		
>
<dtd publicid="-//Sun Microsystems, Inc.//DTD Enterprise JavaBeans 2.0//EN"
         location= "D:\stride\vfcstride\strideEJB\ejbModule\META-INF\ejb-
jar_2_0.dtd" />
  <include name="**/ejb-jar.xml"/>
  <include name="**/ibm-ejb-jar-bnd.xml"/>
<websphere dbvendor="DB2UDBWIN_V71"
                 ejbdeploy="true"
                 destdir="${srcDir}\strideEJB">
     
             
  
      <classpath>
        <path refid="ejbdeploy.classpath"/>
      </classpath>
</websphere>

On executing this build i get the following error....


Buildfile: build.xml

init:
   [ejbjar] building ejb.jar with 41 files

[ejbdeploy] Class "com.ibm.etools.ejbdeploy.plugin.EJBDeployPlugin" must not be 
on the classpath
[ejbdeploy] com.ibm.etools.ejbdeploy.ConfigurationError: 
Class "com.ibm.etools.ejbdeploy.plugin.EJBDeployPlugin" must not
be on the classpath
[ejbdeploy]     at com.ibm.etools.ejbdeploy.batch.impl.BatchDeploy.startup
(BatchDeploy.java:204)
[ejbdeploy]     at com.ibm.etools.ejbdeploy.EJBDeploy.startup
(EJBDeploy.java:380)
[ejbdeploy]     at com.ibm.etools.ejbdeploy.EJBDeploy.execute(EJBDeploy.java:77)
[ejbdeploy]     at com.ibm.etools.ejbdeploy.EJBDeploy.main(EJBDeploy.java:307)
[ejbdeploy] EJBDeploy level: 20030726_2016-WB211-AD-V51D-GM
[ejbdeploy] Java Result: 1
BUILD SUCCESSFUL
Total time: 6 seconds


I have tried everything from unzipping the jars...to setting the classpaths 
explicitly in the environment variables for the jars listed, to putting the 
jars in the ANT\lib folder..

Also note that I am using WSAD 5.1 and ANT 1.6.2 and JDK 1.3(The one supplied 
with WSAD).

This is very urgent...

Are there any morejars that i need....? If yes please list them

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message