ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jesse Glick <jesse.gl...@sun.com>
Subject Drop 1.2/1.3 support in Ant 1.7 (or sometime)?
Date Wed, 06 Apr 2005 20:01:56 GMT
Has anyone given thought to when we drop support for running Ant on JDK 
1.2/1.3? These releases are pretty old by now and AFAIK all major 
platforms have had a decent 1.4 port for a while. I am guessing most 
Java developers would be using a relatively recent JDK anyway - and 
those who are still using 1.2/1.3 probably don't expect to be able to 
use the latest releases of every tool like Ant, either.

Continuing to support 1.2 and 1.3 means we need to continue to have 
various hacks in the codebase - long if/else clauses, reflection - which 
could otherwise be removed. It means more codepaths, thus harder code to 
read and more of a testing burden. It also means we cannot easily use 
JDK 1.4+ APIs, and cannot use assertions at all.

Cross-development could continue to be supported (if desired) with the 
existing 'bootclasspath' and 'executable' attributes on various tasks, 
which AFAIK is now complete with 'executable' added to <javadoc>.

Granted I am probably biased as a Sun employee, since JDK 1.2 & 1.3 are 
officially at "end of life". But note that you can't even run the last 
JDK 1.2 maintenance release on a recent Linux distribution, unless you 
use an obscure LD_PRELOAD hack (*).

Opinions? Just testing the waters here, nothing urgent.

-J.

(*) Cf.:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=134160#c1
http://www.gesinet.it/oracle/oracle9ionsles9amd64.html

-- 
jesse.glick@sun.com   x22801   netbeans.org   ant.apache.org
if I had known it was harmless I would have killed it myself


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message