ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 34659] New: - ANT_HOME containing Japanese (non-ascii) characters prevents ant from starting
Date Thu, 28 Apr 2005 05:24:58 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=34659>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=34659

           Summary: ANT_HOME containing Japanese (non-ascii) characters
                    prevents ant from starting
           Product: Ant
           Version: 1.6.2
          Platform: PC
        OS/Version: Windows 2000
            Status: NEW
          Severity: minor
          Priority: P2
         Component: Core
        AssignedTo: dev@ant.apache.org
        ReportedBy: dies@hst.fujitsu.com


I installed Ant under a directory that contains Japanese characters:
ANT_HOME=F:\sources\compile_environment\&#12486;&#12473;&#12488;&#65298;\apache-ant-1.6.3beta1

It won't start:
F:\sources\compile_environment\&#12486;&#12473;&#12488;&#65298;>apache-ant-1.6.3beta1\bin\ant.bat
java.lang.ClassNotFoundException: org.apache.tools.ant.Main
        at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:187)

If I rename the Japanese part into something English and redefine ANT_HOME it
works fine:

F:\sources\compile_environment\test2>set
ANT_HOME=F:\sources\compile_environment\test2\apache-ant-1.6.3beta1

F:\sources\compile_environment\test2>apache-ant-1.6.3beta1\bin\ant.bat
Buildfile: build.xml
...

It happens with both 1.6.2 and 1.6.3beta1.
My OS is Windows 2000 Server Japanese, java version "1.4.2_05" (Java HotSpot(TM)
Server VM (build 1.4.2_FUJITSU_MODIFIED-B10, mixed mode))

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message