ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject AW: [patch] mainly name-hiding
Date Fri, 11 Mar 2005 07:21:06 GMT
> No doubt - I'm not sure that Jikes should dictate the code.

> Personally, I primarily use terneraries for situations such 
> as parameter 
> passing, where I need to pass one of two values. In general, I much 
> prefer readable code with good variable names over smaller code with 
> abbrv vrbl nms.

You can configure Eclipse for finding name hiding, too. But I also think
that WE should name our variables not just a tool, because WE have to read
the code - not only the compiler.
So it´s the same with if & ternaries. If it´s "just" a choice between two
"static" values its ok (short, readable). But you should not create cascades
of them.
:-) what about

  return (callee != null ? calle : super).handleInput(buffer, offset,


I think we could change the names for getting rid of name hiding, but then
readable names.


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message