ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 33978] New: - BUILD FAILED - Can't find javac, but it's there
Date Sat, 12 Mar 2005 20:41:24 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=33978>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=33978

           Summary: BUILD FAILED - Can't find javac, but it's there
           Product: Ant
           Version: 1.6.2
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Build Process
        AssignedTo: dev@ant.apache.org
        ReportedBy: elshoff@wldelft.nl
                CC: elshoff@wldelft.nl


I'm trying to build Ant 1.6.2 on Fedora Core 3 Linux, with Kaffe 1.1.4 as JDK. 
There are the steps I take:

    export JAVA_HOME=/opt/kaffe
    PATH="$JAVA_HOME:/bin:$PATH
    ./build.sh -Ddist.dir=/opt/ant

After using a modified bootstrap.sh (see bug 33977), I get:

    ... Bootstrapping Ant Distribution
    ... Compiling Ant Classes
    ... Copying Required Files
    ... Building Ant Distribution
    Buildfile: build.xml

    bootstrap:

    prepare:

    check_for_optional_packages:

    javac.preset.1.5+:

    javac.preset.1.5-:

    javac.preset:

    build:
    Created dir: /part0/opt/ant-1.6.2/src/apache-ant-1.6.2/build/lib
    Compiling 201 source files to
/part0/opt/ant-1.6.2/src/apache-ant-1.6.2/build/classes

    BUILD FAILED
    /part0/opt/ant-1.6.2/src/apache-ant-1.6.2/build.xml:1060: The following
error occurred while executing this line:
    /part0/opt/ant-1.6.2/src/apache-ant-1.6.2/build.xml:628: Unable to find a
javac compiler;
    com.sun.tools.javac.Main is not on the classpath.
    Perhaps JAVA_HOME does not point to the JDK

    Total time: 5 seconds
    ... Failed Building Ant Distribution !
    Bootstrap FAILED

There is a javac in my PATH (/opt/kaffe/bin/javac), so I have no idea why Ant
complains.

CLASSPATH and ANT_HOME are undefined.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message