ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 33703] New: - Ant 1.6.2 CLASSPATH broken under cygwin
Date Wed, 23 Feb 2005 02:59:33 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=33703>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=33703

           Summary: Ant 1.6.2 CLASSPATH broken under cygwin
           Product: Ant
           Version: 1.6.2
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Core
        AssignedTo: dev@ant.apache.org
        ReportedBy: michi@zeroc.com


I'been running ant for an existing project with a CLASSPATH setting something 
like:

$ echo $CLASSPATH
.;./classes;C:/cygwin/home/michi/src/icej/lib/Ice.jar;C:/cygwin/home/michi/src/
packages_win32/lib/db.jar

This is under cygwin. This setting has worked fine for the last two years but 
fails as of ant 1.6.2. When compiling, ant concludes that none of the 
components in the CLASSPATH exist. Here is the output from a run with ant -
verbose:

    [javac] Using modern compiler
dropping C:\cygwin\home\michi\src\icej\C:\cygwin\home\michi\src\icej\.\classes 
from path as it doesn't exist
dropping C:\cygwin\home\michi\src\icej\C:\cygwin\home\michi\src\icej\C from 
path as it doesn't exist
dropping 
C:\cygwin\home\michi\src\icej\C:\cygwin\cygwin\home\michi\src\icej\lib\Ice.jar 
from path as it doesn't exist
dropping 
C:\cygwin\home\michi\src\icej\C:\cygwin\cygwin\home\michi\src\packages_win32
\lib\db.jar from path as it doesn't
 exist

After some tinkering, I found that changing the forward slashes in my 
CLASSPATH to backslashes fixed the problem.

It would be nice to have the old behavior back.

Cheers,

Michi.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message