ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <>
Subject javac: target release 1.1 conflicts with default source release 1.5
Date Wed, 26 Jan 2005 11:52:22 GMT

after I've been watching the JDK 1.5 builds of Gump for weeks now,
I've pretty much given up the hope that projects are going to adapt
the build files to JDK 1.5 soon.  Xalan's build breaks because they
only specify the target attribute and quite a few others do so as
well.  (as a sidenote, Xalan's XSLT is supposed to be part of JDK 1.5,
I find it slightly amusing that you can't build it with it).

Finally I've come to the conclusion that Ant should take care of it.
I therefore propose the following:


* we are going to use JDK 1.5 for compiling

* _and_ -target has been specified

* _and_ -target is smaller than 1.5

* _and_ -source has not been specified


* print a big fat warning telling people to specify the source

* implicitly set -source to the same value as -target.

Since we don't know what JDK 1.6's javac's default is going to be I'd
stick with handling the 1.5 case now.

Anybody against applying this magic?


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message