ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 33279] New: - SSH2 Password Authentication is broken
Date Thu, 27 Jan 2005 23:32:52 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=33279>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=33279

           Summary: SSH2 Password Authentication is broken
           Product: Ant
           Version: 1.6.2
          Platform: PC
        OS/Version: Windows 2000
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Optional Tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: mattinger@yahoo.com


When trying to use the <sshexec> task, i am getting the following error:

     [exec] cvsup:
     [exec]   [sshexec] Connecting to ind-cvs:22

     [exec] BUILD FAILED
     [exec] E:\build-utilities\new-web-interface\dist\scripts\cvsup.xml:42: com.
jcraft.jsch.JSchException: reject HostKey

     [exec] Total time: 3 seconds

register.finish:
      [sql] Executing commands
      [sql] 1 of 1 SQL statements executed successfully

BUILD SUCCESSFUL
Total time: 5 seconds



I am trying to run a command via ssh, with the following ant spec:

        <sshexec
            host="${cvsup.host}"
            port="${cvsup.port}"
            username="${cvsup.username}"
            password="${cvsup.password}"
            command="${cvsup.command}" />

>From what i've tried, i've seen this error when using JSch directly,
and the following code eliminates that error:

        Hashtable config = new Hashtable();
        config.put("StrictHostKeyChecking", "no");
        session.setConfig(config);

However, the <sshexec> task does not allow any option for this.
It would be nice if there were a property which could be set on
the task to enable the setting of this configuration item.

Other than that config item, i have not found a way to use password
authentication.  If there are suggestions, that would be nice.

I am willing to make this fix myself, and contribute the patch if
it is indeed the proper way to handle this.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message