ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 30921] - Quotes in CLASSPATH can screw up ant.bat
Date Thu, 06 Jan 2005 20:06:11 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=30921>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=30921


brantgurganus2001@cherokeescouting.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         OS/Version|                            |All




------- Additional Comments From brantgurganus2001@cherokeescouting.org  2005-01-06 21:06
-------
I have a solution, at least for my case which is:
CLASSPATH="C:\Program Files\junit3.8.1\junit.jar"

The solution was to modify the first line of :runAnt from:

if not "%CLASSPATH%"=="" goto runAntWithClasspath

to:

if not %CLASSPATH%=="" goto runAntWithClasspath

I thought that this solution would not work when there were other classpath
elements with quotation marks around them.  I set my classpath to:
CLASSPATH="C:\Program Files\junit3.8.1\junit.jar";""

Even after that change, the wrapper batch file did not complain.  If other
people can confirm that this change does not cause problems, this change could
be patched in to solve this problem.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message