ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martijn Kruithof ...@kruithof.xs4all.nl>
Subject Re: cvs commit: ant/src/main/org/apache/tools/ant/taskdefs/compilers Jikes.java
Date Wed, 08 Dec 2004 07:13:58 GMT
Hi

>           if (attributes.getSource() != null) {
>               cmd.createArgument().setValue("-source");
>  -            cmd.createArgument().setValue(attributes.getSource());
>  +            String source = attributes.getSource();
>  +            if (source.equals("1.1") || source.equals("1.2")) {
>  +                // support for -source 1.1 and -source 1.2 has been
>  +                // added with JDK 1.4.2, Jikes doesn't like it
>  +                cmd.createArgument().setValue("1.3");
>  +            } else {
>  +                cmd.createArgument().setValue(source);
>  +            }
>           }
>   
>           addCurrentCompilerArgs(cmd);
>  
> 
>
Shouldn't we at least log some kind of warning when we ignore 1.1 or 1.2?
like
attributes.log("Jikes does not support -source " + source + ". Using 
-source 1.3 instead", Project.MSG_WARN);

Kind regards, Martijn

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message