ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 32163] New: - Telnet not working in Solaris
Date Wed, 10 Nov 2004 17:47:30 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=32163>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=32163

Telnet not working in Solaris

           Summary: Telnet not working in Solaris
           Product: Ant
           Version: 1.6.2
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Optional Tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: richard.choi@na.whiteclarkegroup.com


When I run the ant task in XP and connect to Solaris, it works. However, if I 
run the same script from Solaris, it doesn't do anything.
Here is the script
<target name="execute_load" >
    <echo> Running sql loader tool </echo>
    <telnet server="${UnixServer}" userid="${UnixUserID}" 
password="${UnixUserPasswd}">
     <read>${WaitFor}</read>
        <write>echo $WL_HOME > abc</write>
   </telnet>
  </target>

Here is the output
$ lps_load.sh
exec "/usr/java1.3.1/bin/java" -
classpath "/lsnrs/richard.choi/migrationTools/apache-ant-1.6.2/lib/ant-
launcher.jar" -Dant.home="/lsnrs/richard.choi/migrationTools/apache-ant-
1.6.2" -Dant.library.dir="/lsnrs/richard.choi/migrationTools/apache-ant-
1.6.2/lib" org.apache.tools.ant.launch.Launcher -lib "" "-version"
Apache Ant version 1.6.2 compiled on July 16 2004
java version "1.3.1_01"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1_01)
Java HotSpot(TM) Client VM (build 1.3.1_01, mixed mode)
/lsnrs/richard.choi/migrationTools/apache-ant-1.6.2/lib/commons-net-
1.2.2.jar:/lsnrs/richard.choi/migrationTools/apache-ant-1.6.2/lib/ant-apache-
oro.jar:/lsnrs/richard.choi/migrationTools/apache-ant-
1.6.2/lib/optional.jar:./jsch-0.1.15.jar
exec "/usr/java1.3.1/bin/java" -
classpath "/lsnrs/richard.choi/migrationTools/apache-ant-1.6.2/lib/ant-
launcher.jar" -Dant.home="/lsnrs/richard.choi/migrationTools/apache-ant-
1.6.2" -Dant.library.dir="/lsnrs/richard.choi/migrationTools/apache-ant-
1.6.2/lib" org.apache.tools.ant.launch.Launcher -
lib "/lsnrs/richard.choi/migrationTools/apache-ant-1.6.2/lib/commons-net-
1.2.2.jar:/lsnrs/richard.choi/migrationTools/apache-ant-1.6.2/lib/ant-apache-
oro.jar:/lsnrs/richard.choi/migrationTools/apache-ant-
1.6.2/lib/optional.jar:./jsch-0.1.15.jar" "-f" "load_lps.xml" "execute_load"
Buildfile: load_lps.xml

execute_load:
     [echo]  Running sql loader tool
   [telnet]
   [telnet]
   [telnet] SunOS 5.7
   [telnet]
   [telnet]
   [telnet] login:
   [telnet] richard.choi
   [telnet]  Password:
   [telnet]
   [telnet] Last login: Wed Nov 10 12:13:57 from wcna-p4lap008.na
   [telnet] Sun Microsystems Inc.   SunOS 5.7       Generic October 1998
   [telnet] You have mail.
   [telnet] Hi, Richard
   [telnet] echo $WL_HOME > abc

BUILD SUCCESSFUL
Total time: 1 second

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message