ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bode...@apache.org
Subject cvs commit: ant/src/main/org/apache/tools/ant/taskdefs/optional/extension Extension.java
Date Fri, 05 Nov 2004 15:02:05 GMT
bodewig     2004/11/05 07:02:05

  Modified:    src/main/org/apache/tools/ant/taskdefs/optional/extension
                        Extension.java
  Log:
  Make getCompatibilityWith actually compare two different values.
  
  PR: 31360
  Submitted by:	David Gärtner <david dot gaertner at syngenio dot de>
  
  Revision  Changes    Path
  1.13      +10 -10    ant/src/main/org/apache/tools/ant/taskdefs/optional/extension/Extension.java
  
  Index: Extension.java
  ===================================================================
  RCS file: /home/cvs/ant/src/main/org/apache/tools/ant/taskdefs/optional/extension/Extension.java,v
  retrieving revision 1.12
  retrieving revision 1.13
  diff -u -r1.12 -r1.13
  --- Extension.java	9 Mar 2004 16:48:23 -0000	1.12
  +++ Extension.java	5 Nov 2004 15:02:05 -0000	1.13
  @@ -444,31 +444,31 @@
           }
   
           // Available specification version must be >= required
  -        final DeweyDecimal specificationVersion
  +        final DeweyDecimal requiredSpecificationVersion
               = required.getSpecificationVersion();
  -        if (null != specificationVersion) {
  +        if (null != requiredSpecificationVersion) {
               if (null == specificationVersion
  -                || !isCompatible(specificationVersion, specificationVersion)) {
  +                || !isCompatible(specificationVersion, requiredSpecificationVersion)) {
                   return REQUIRE_SPECIFICATION_UPGRADE;
               }
           }
   
           // Implementation Vendor ID must match
  -        final String implementationVendorId
  +        final String requiredImplementationVendorID
               = required.getImplementationVendorID();
  -        if (null != implementationVendorId) {
  +        if (null != requiredImplementationVendorID) {
               if (null == implementationVendorID
  -                || !implementationVendorID.equals(implementationVendorId)) {
  +                || !implementationVendorID.equals(requiredImplementationVendorID)) {
                   return REQUIRE_VENDOR_SWITCH;
               }
           }
   
           // Implementation version must be >= required
  -        final DeweyDecimal implementationVersion
  +        final DeweyDecimal requiredImplementationVersion
               = required.getImplementationVersion();
  -        if (null != implementationVersion) {
  +        if (null != requiredImplementationVersion) {
               if (null == implementationVersion
  -                || !isCompatible(implementationVersion, implementationVersion)) {
  +                || !isCompatible(implementationVersion, requiredImplementationVersion))
{
                   return REQUIRE_IMPLEMENTATION_UPGRADE;
               }
           }
  
  
  

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message