ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 32066] - <exec> favours .exe over .com
Date Thu, 04 Nov 2004 22:07:00 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=32066>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=32066

<exec> favours .exe over .com





------- Additional Comments From junk@bbs.darktech.org  2004-11-04 22:07 -------
Matt,

I can't test under anything other than WinXP since I don't have anything else.
You can find more information on the issue here:

http://www.google.ca/search?q=cache:gpHR5UnC_NwJ:www.mail-archive.com/user%40ant.apache.org/msg11390.html+ant+devenv&hl=en

or

http://groups.google.ca/groups?hl=en&lr=&threadm=estP9.67050%24Nz5.1996252%40twister.austin.rr.com&rnum=1&prev=/groups%3Fhl%3Den%26lr%3D%26q%3Dant%2Bdevenv%26btnG%3DSearch

These are links to discussions of other people on the same issue. I think the
best way for you to reproduce the problem is to try it on your end. The code
sniplet I am using in ANT is:

	<target name="compile.native.debug" depends="generate.native.proxy"
description="Compiles native components">
		<exec executable="devenv.com" failonerror="true">
			<arg line="/build debug"/>
			<arg file="c++/vc++7.1/vc++7.1.sln"/>
		</exec>
	</target>

  If you rename "devenv.com" to simply "devenv" you will not you get no output.
The only thing you need to run devenv is some sample VC++ project/solution (I
use vc++7.1.sln in my case).

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message