ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Conor MacNeill <co...@cortexebusiness.com.au>
Subject Re: AW: Is 1.4 the minimum Java API level?
Date Tue, 19 Oct 2004 06:35:10 GMT

Jan.Materne@rzf.fin-nrw.de wrote:
> Ant´s core has to be compilable and runnable with JDK 1.2 [1].
> Other classes must be included via reflection.
> 
> Jan
> 
> [1] http://ant.apache.org/ant_task_guidelines.html
>     Support Java 1.2 through Java 1.4
> 

Just to expand a little there - most tasks are not considered part of 
the Ant core and can make use of features from JDKs after 1.2.

The Ant build file contains a series of selectors to control which 
classes it attempts to compile based on the JDK version.

Conor

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message