ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Loughran <>
Subject hotswap
Date Fri, 08 Oct 2004 17:02:29 GMT

On Thu, 07 Oct 2004 19:02:39 -0400, David Kavanagh <> wrote:
 > I just noticed a 1.5+ feature that is going into Ant 1.7. Many months
 > ago, I had a 1.4+ feature that I wanted to get put into Ant, but it was
 > rejected because it wouldn't be backward compatible to version 1.2.2.
 > Has something changed? If so, I'd like to offer the <hotswap> target. It
 > has a home at and I'd be happy to
 > contribute that to the main ant project. I've been using it at work in
 > our builds for all that time and it is robust and ready to be used.

Assuming the code is self contained and isolated from bootstrap.bat/sh, 
we can have optional version code in the system, sorry if that was an 
issue before.

Having had a look at hotswap, I dont know whether to be impressed or 
scared. Are you using this for hot deployment to a live system, wow. Not 
in production, one would hope.

At the very least we can link to it on the web site, it is a very wild 
idea. As to whether we'd want it in the core (putting aside the fact 
that you'd need to add an apache-compatible license ), I am scared of 
its powers. Only to be used in the hands of the competent, i think. But 
its potentially no worse than any normal debugger. And it is certainly a 
task closely related to the build/deploy process.

So I will ask other people to give their opinion.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message