ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 31965] New: - cvs failonerror target fails even though there's no error
Date Fri, 29 Oct 2004 16:46:03 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=31965>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=31965

cvs failonerror target fails even though there's no error

           Summary: cvs failonerror target fails even though there's no
                    error
           Product: Ant
           Version: 1.5.4
          Platform: Other
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: Build Process
        AssignedTo: dev@ant.apache.org
        ReportedBy: mpuckett@granite.com


Here's the target I'm trying to run to trap for any cvs errors

<target name="checkout">
  <cvs command="checkout"
     package="module"
     quiet="true"
     failonerror="true"/>
</target>

It gets to the end of the checkout and I get:

BUILD FAILED
file:testbuild.xml:97 cvs exited with error code 1
Command line was 'q' 'checkout' 'module'

I can do the cvs command from command line w/out a problem.

I need to trap for errors and this is reporting an error when there
really wasn't one.

Thanks (cvs 1.11.12)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message