ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 31598] - XmlLogger does not output to logfile
Date Thu, 28 Oct 2004 14:33:47 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=31598>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=31598

XmlLogger does not output to logfile





------- Additional Comments From claude.ostyn@barco.com  2004-10-28 14:33 -------
Well, it's Ant's own ant.bat script file.
After further investigation, I think I found out what the problem is and how to
bypass it:
in the ant.bat there's a section that 'slurps' the command line arguments and 
apparently this is where it goes wrong. When I replace all that slurping stuff
with the following command line, it works fine:
set ANT_CMD_LINE_ARGS=%1 %2 %3 %4 %5 %6 %7 %8 %9
This is not so fancy, but it works for me. 

This is the complete altered section:
---snip---
rem Slurp the command line arguments. This loop allows for an unlimited number
rem of arguments (up to the command line limit, anyway).
rem if ""%1""=="""" goto doneStart
rem shift
rem :setupArgs
rem if ""%1""=="""" goto doneStart
rem set ANT_CMD_LINE_ARGS=%ANT_CMD_LINE_ARGS% %1
rem shift
rem This label provides a place for the argument list loop to break out
rem and for NT handling to skip to.
set ANT_CMD_LINE_ARGS=%1 %2 %3 %4 %5 %6 %7 %8 %9
---snap---

So, perhaps the problems are due to my system, but with that altered line, I can
bypass the problem.

Thanks for your effort ...

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message