ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 31438] New: - Misleading error message when removing "-" from "-buildfile" option
Date Mon, 27 Sep 2004 15:19:03 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=31438>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=31438

Misleading error message when removing "-" from "-buildfile" option

           Summary: Misleading error message when removing "-" from "-
                    buildfile" option
           Product: Ant
           Version: 1.5.4
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Core tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: jackwang@ca.ibm.com
                CC: jackwang@ca.ibm.com


I used ANT utility with a buildfile createInstance.xml (different from the 
default build.xml) for -buildfile option, but forgot "-" for "-buildfile", and 
ANT throwed an error as follows,
Buildfile: build.xml does not exist!

This error message is misleading and I expect to see a more helpful message to 
point out the syntax error with -buildfile option, ie, the missing "-". Thanks.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message