ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 28135] - <exec> task hangs Ant on some Windows configurations
Date Mon, 20 Sep 2004 11:49:28 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=28135>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=28135

<exec> task hangs Ant on some Windows configurations





------- Additional Comments From alexmcmanus@bigfoot.com  2004-09-20 11:49 -------
I've attached two files that may demonstrate symptoms of the same underlying 
problem. 

TomcatTest.xml does a spawned exec on the Tomcat startup.bat file. If you run 
this directly, Tomcat starts and the script exits as you would expect.

ExecTest.xml does an exec command on Ant, to run TomcatTest (i.e. there is a 
nested exec). Under this scenario, it reports that TomcatTest builds 
successfully, but the process does not exit (the "After" message in 
ExecTest.xml is never reached). If I shutdown Tomcat from the Start menu, the 
Ant build then completes.

The only workaround that I have for this is to spawn both exec commands. 

You will need to edit the path to Ant in ExecTest.xml and the path to Tomcat in 
TomcatTest.xml to get this working.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message