ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Loughran <ste...@apache.org>
Subject Re: AW: classloader test failing
Date Wed, 04 Aug 2004 08:40:47 GMT

Think I've found my problem. Once you run ant testutil to create an 
ant-testutil.jar , which then propagates to various lib directories, you 
have no end of obscure classloader related failures. All fixed.



Jan.Materne@rzf.fin-nrw.de wrote:
> Testing on W2K SP4, JDK 1.4.2 ...
>   rd /Q/S bootstrap
>   build -D"test.haltonfailure=false" install-lite test
> 
> run-tests:
>     [junit] Testsuite: org.apache.tools.ant.AntClassLoaderDelegationTest
>     [junit] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 0,03 sec
> 
> 
> Jan
> 
> 
> 
>>-----Urspr√ľngliche Nachricht-----
>>Von: Antoine Levy-Lambert [mailto:antoine@gmx.de]
>>Gesendet am: Dienstag, 3. August 2004 12:33
>>An: Ant Developers List
>>Betreff: Re: classloader test failing
>>
>>Hello Steve,
>>
>>Not sure when I will have the time to look into it.
>>
>>I am sure that the test worked for me on Windows 2000.
>>
>>What I usually do is :
>>rm -rf bootstrap; ./build.sh -D"test.haltonfailure=false" 
>>install-lite test
>>
>>I hope it is just a build.xml or testcase problem, rather 
>>than a problem
>>with the code itself.
>>
>>Cheers,
>>
>>Antoine
>>
>>
>>Steve Loughran wrote :
>>
>>>classloader test fails on suse9.1, java1.4.2 when invoked 
>>
>>via build test 
>>
>>>or ant test:
>>>
>>>
>>>I'm also seeing a failure on winxp (SP2) when I run it from "build 
>>>test", but not "ant test".
>>
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
>>For additional commands, e-mail: dev-help@ant.apache.org
> 
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message