ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam R. B. Jack" <aj...@apache.org>
Subject Re: [GUMP@brutus]: ant/test-ant failed
Date Wed, 11 Aug 2004 14:15:44 GMT
>      [csc] ** ERROR **: file critical-sections.c: line 89 (DeleteCriticalSection): assertion
failed: (ret == 0)
>      [csc] aborting...
>
> BUILD FAILED
> /home/bodewig/repo/cvs/asf/ant/src/etc/testcases/taskdefs/optional/dotnet.xml:155: csc
returned: 129
> 	at org.apache.tools.ant.taskdefs.optional.dotnet.NetCommand.runCommand(NetCommand.java:293)
>
> This looks fine from the Ant side and seems to be an issue with the
> Mono installation (as expected).  Compilation succeeds but mono (the
> VM running the compiler) fails with an error I've never seen before.

Wild-arsed guess, but I wonder if Brutus' two CPUs have something to do with this.

> Do we already have a Mono 1.0.1 available for Debian?

I've forwarded the output/error to the Mono Debian list. If that goes nowhere I'll try to
report to any Mono list. Doing a Google I see a few folks have posted this type of problem
(on various versions) but I think it might be a side-effect of abnormal termination. A bug
yes, but a bug due to an earlier  seemingly unrelated failure. Any way to run this with more
debug, or more information?

Is there a simpler test we can run? Can we work on a <nant target and do some realy small
simple things to start with and work up?

regards,

Adam

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message