ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Loughran <ste...@apache.org>
Subject Re: basedir not set corretly in subant task...
Date Wed, 14 Jul 2004 09:27:42 GMT
Dominique Devienne wrote:

>>-----Original Message-----
>>From: Alan Brown [mailto:abrown@symyx.com]
>>
>>I have a master build file in Project that uses the Ant task to call
>>targets in slave build files in the directories below it (tools, server
>>and client).  One of these slave build files (Tools) uses Subant to call
>>build files dynamically in directories below it.  However, in this
>>scenario the baseDirectory is not set correctly and remains as the Tools
>>directory.
>>
>>This is confirmed by the fact that all runs perfectly well if I run 'ant
>>build' directly from the Tools directory.  It's only running it from
>>Project that causes the failure.
>>
>>Does anyone know a workaround to this problem?
> 
> 
> It may be a bug indeed!?
> 
> But a possible work around would to not use <ant> from the master build, but
> <subant> as well, or use <ant> is such a way that you do not override the
> basedir of the Tools build.
> 
> The problem might be the interaction of <ant> + <subant>. --DD
> 

Interesting...I've been seeing the same thing, but thought it was 
something of mine, not a real bug. Now I am not so sure.




---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message