ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 28996] New: - [PATCH] Permit building under JDK 1.5 beta 2
Date Sat, 15 May 2004 00:07:12 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=28996>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=28996

[PATCH] Permit building under JDK 1.5 beta 2

           Summary: [PATCH] Permit building under JDK 1.5 beta 2
           Product: Ant
           Version: 1.6.1
          Platform: PC
               URL: http://developer.java.sun.com/developer/bugParade/bugs/5
                    028634.html
        OS/Version: Linux
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Build Process
        AssignedTo: dev@ant.apache.org
        ReportedBy: jglick@netbeans.org


I have heard that JDK 1.5 beta 2 will set the default -source to 1.5. (See URL.)
But this breaks the Ant build because it sets -target to 1.1 (actually 1.2 would
probably be fine for Ant 1.6+) which cannot support 1.5 source.

The attached patch just sets both source and target to 1.2 and lets Ant be
compiled normally (./build.sh) using JDK 1.5 beta 2. Anyway it is preferable to
explicitly define the source level to avoid accidents.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message