ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: [GUMP@lsd]: ant/ant-testutil failed
Date Mon, 29 Mar 2004 07:16:20 GMT
On Sat, 27 Mar 2004, Matt Benson <gudnabrsam@yahoo.com> wrote:

> Can someone explain to me how to go about determining
> the reason for the failure, as far as what happened
> with Gump?

Go to
<http://lsd.student.utwente.nl/gump/ant/gump_work/build_ant_test-ant.html>
and search for the failed test.  Gump is trying to be helpful and has
turned on debug info by now (it does so if a build fails repeatedly)
and in our case it mostly blurs the picture.

It seems as if

    [junit] Testsuite: org.apache.tools.ant.taskdefs.optional.image.ImageTest
    [junit] Tests run: 4, Failures: 1, Errors: 0, Time elapsed: 4.129 sec

    [junit] Testcase: testOverwriteTrue(org.apache.tools.ant.taskdefs.optional.image.ImageTest):
FAILED
    [junit] File was not overwritten.
    [junit] junit.framework.AssertionFailedError: File was not overwritten.
    [junit] 	at junit.framework.Assert.fail(Assert.java:47)
    [junit] 	at junit.framework.Assert.assertTrue(Assert.java:20)
    [junit] 	at org.apache.tools.ant.taskdefs.optional.image.ImageTest.testOverwriteTrue(ImageTest.java:82)
    [junit] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    [junit] 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    [junit] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    [junit] 	at java.lang.reflect.Method.invoke(Method.java:324)
    [junit] 	at junit.framework.TestCase.runTest(TestCase.java:154)
    [junit] 	at junit.framework.TestCase.runBare(TestCase.java:127)
    [junit] 	at junit.framework.TestResult$1.protect(TestResult.java:106)
    [junit] 	at junit.framework.TestResult.runProtected(TestResult.java:124)
    [junit] 	at junit.framework.TestResult.run(TestResult.java:109)
    [junit] 	at junit.framework.TestCase.run(TestCase.java:118)
    [junit] 	at junit.framework.TestSuite.runTest(TestSuite.java:208)
    [junit] 	at junit.framework.TestSuite.run(TestSuite.java:203)
    [junit] 	at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.run(JUnitTestRunner.java:285)
    [junit] 	at org.apache.tools.ant.taskdefs.optional.junit.JUnitTask.executeInVM(JUnitTask.java:960)
    [junit] 	at org.apache.tools.ant.taskdefs.optional.junit.JUnitTask.execute(JUnitTask.java:632)
    [junit] 	at org.apache.tools.ant.taskdefs.optional.junit.JUnitTask.execute(JUnitTask.java:606)
    [junit] 	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:268)
    [junit] 	at org.apache.tools.ant.Task.perform(Task.java:363)
    [junit] 	at org.apache.tools.ant.Target.execute(Target.java:301)
    [junit] 	at org.apache.tools.ant.Target.performTasks(Target.java:328)
    [junit] 	at org.apache.tools.ant.Project.executeTarget(Project.java:1214)
    [junit] 	at org.apache.tools.ant.Project.executeTargets(Project.java:1062)
    [junit] 	at org.apache.tools.ant.Main.runBuild(Main.java:667)
    [junit] 	at org.apache.tools.ant.Main.startAnt(Main.java:187)
    [junit] 	at org.apache.tools.ant.Main.start(Main.java:151)
    [junit] 	at org.apache.tools.ant.Main.main(Main.java:234)


    [junit] TEST org.apache.tools.ant.taskdefs.optional.image.ImageTest FAILED

is the problem.

I add JAI to Ant's CLASSPATH last Friday and thus the JAI related
tasks and tests have been added.  Your changes look absolutely fine
(from Gump's POV) but the JAI tests seem to fail.  Probably a timing
issue, many test failures in Gump are timing problems.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message