ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 26757] - sshexec hangs
Date Thu, 18 Mar 2004 08:25:57 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=26757>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=26757

sshexec hangs





------- Additional Comments From glee@ebay.com  2004-03-18 08:25 -------
I am also seeing this bug.  Using the following snippet...
	  <echo>Creating dir
${global.deploy.machinename}:${global.deploy.target.dir}</echo>
	  <sshexec host="${global.deploy.machinename}"
		  username="${global.deploy.remote.user}"
		  trust="true"
		  password="${global.deploy.remote.password}"
		  command="perl -ver"
		  timeout="60000" />
	  <echo>finished with perl</echo>

For us it seems to work against a sun solaris box but fails when trying to
connect to f-secure sshd service running on w2k.  Our client box is a w2k box
running ant 1.6.1

The behavior is that it returns output for the command, but hangs there until
the timeout is exceeded and then it fails.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message