ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: [VOTE] date for 1.6.1 final
Date Fri, 06 Feb 2004 07:42:10 GMT
On Thu, 05 Feb 2004, Steve Loughran <steve_l@iseran.com> wrote:

> The one interesting issue is that as Java1.5 beta has just shipped,
> we should test against that to see if there are any surprises that
> we can fix in 1.6.1.

;-)

<http://stefanbodewig.blogger.de/stories/50816/>
<http://marc.theaimsgroup.com/?l=ant-dev&m=107528601129819&w=2>
<http://stefanbodewig.blogger.de/stories/59918/>

Ant 1.6.0 doesn't allow you to use source="1.5" in <javac>, 1.6.1
will.

At least on the Linux version, the -target switch for javac is broken
(in the JDK, not in Ant) as -target 1.1 will produce 1.4 classes
anyway.  And the default value for -source seems to have changed as
the JDK complains about -target 1.1 unless you also explicitly set
-source 1.3.  It looks as if 1.4 was the new default.

I just don't want to adapt anything here before I see the docs for JDK
1.5 as it is hard to tell what has been changed intentionally and what
is a bug in the JDK.

I have successfully bootstrapped Ant with 1.5 and ran the testsuite.
I didn't try the javadoc task (but that should be trivial) or rmi
(hmm, could try to build JMeter).  I don't have any project that uses
javah, though.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message