ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 26108] - delete task fails for jar file in CWD on WNT
Date Mon, 01 Mar 2004 03:37:23 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=26108>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=26108

delete task fails for jar file in CWD on WNT





------- Additional Comments From hoju@visi.com  2004-03-01 03:37 -------
This affects the Log4j build and is very reproduceable using Ant-1.6.0 and
1.6.1.  Works fine with Ant-1.5.3-1.  When trying to run "ant chainsaw",
existing log4j.jar and chainsaw.jar files are deleted and recreated before
running chainsaw (a log viewer utility).  The build fails on the deletes of the
jars.

To test this out, follow instructions here:
http://logging.apache.org/log4j/docs/chainsaw.html

Specifically, download the "install-chainsaw.xml" which will download
dependencies (jakarta-oro) and grab the log4j CVS.  Then cd into the
"logging-logj" module and type "ant chainsaw".  The first time it will work
since the jar files won't have existed yet.  All subsequent times it fails to
delete the jars and breaks the build.

Note:  I do have a "." in my system classpath.  I haven't tried removing it.  Is
it really the problem though?  Jars don't get added to the classpath unless
absolutely specified.  They don't get put in the classpath simply by being in a
directory in the classpath.

Anyway, it would be great if this could be fixed.

Jake

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message