ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 27226] - Tar files with compression ="gzip" cannot be unzipped on Solaris
Date Thu, 26 Feb 2004 07:22:34 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=27226>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=27226

Tar  files with compression ="gzip" cannot be unzipped on Solaris





------- Additional Comments From gabriele.garuglieri@infoblu.it  2004-02-26 07:22 -------
I think a bit of history is worth here.
I'm using ant through eclipse, and during the last year to build the tar package
i have been using releases of eclipse with embedded 1.5.x ant.
Recently i installed the last release of eclipse 3.0 that comes with and
embedded 1.6.0 ant and yesterday when i repackaged a new distribution of the
application i got the above problem.
Eclipse allows you to change the ANT_HOME to point to an external installation
of ant, so i installed ant 1.6.1 and redirected eclipse to use that
installation, no way, same problem.
So i redirected eclipse to use an old 1.5.3.1 installation that i still have in
my disk and in this case everything works as it always did in the last year.

I'm using GNU gzip and GNU tar on Solaris.
If i try to use unzip command on files built with 1.6.0 and 1.6.1, i get the
following error:
Archive:  infoviabilita-2.3.21-full-install.tar.gz
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of
infoviabilita-2.3.21-full-install.tar.gz or
        infoviabilita-2.3.21-full-install.tar.gz.zip, and cannot find
infoviabilita-2.3.21-full-install.tar.gz.ZIP, period.

Which release of gzip and tar are you using?
Thanks, Gabriele

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message