ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 26642] New: - [PATCH] Ant 1.6.0 cannot run build scripts in directories with non-ASCII names
Date Tue, 03 Feb 2004 18:13:55 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=26642>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=26642

[PATCH] Ant 1.6.0 cannot run build scripts in directories with non-ASCII names

           Summary: [PATCH] Ant 1.6.0 cannot run build scripts in
                    directories with non-ASCII names
           Product: Ant
           Version: 1.6.0
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Core
        AssignedTo: dev@ant.apache.org
        ReportedBy: jglick@netbeans.org


I mentioned this problem a while back in bug #8031, but no one seems to have
noticed, so I am opening it separately. #8031 would probably fix it, but there
is a much simpler fix that seems to work as well.

The bug is a regression introduced in 1.6.0 and still present in 1.6.1 beta 1; I
think it is important enough to try to fix in 1.6.1, especially given how easy
it is.

See attached log of the test case which reproduces it easily. The problem is
that FileUtils blindly assumes that all characters in a pathname are ASCII (or,
actually, ISO-8859-1). By just leaving other characters alone, the problem
should be avoided.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message