ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jose Alberto Fernandez" <jalbe...@cellectivity.com>
Subject RE: Selecting XML Parsers
Date Fri, 02 Jan 2004 02:25:05 GMT
		From: Jim Fuller [mailto:jim.fuller@ruminate.co.uk] 
		
		Since v7.1 Saxon is not bound to Aelfred xml parser, and doesn't ship
		with it, Saxon will use by default JVM parser if Aelfred is not on the
		classpath...I am running v7.8 saxon with v1.6.0 Ant with no probs, so
		not so sure that ContextClassLoader is the issue.

I may give a try to newer versions of Saxon. I still think ANT tasks should be more configurable
on how one can manage the classpath for the different standard XML APIs. 
In order to solve the problam I had to invoke ANT with "-lib xercesImpl.jar" so as to make
sure
xerces is first in the classpath. 


		
		M. Kay most recent code is usually very stable, at least near production
		quality and I have been using 7.1 and up with no probs with respect to
		XSLT...though there are issues with XSLT 2.0 and the nascent XQUERY
		implementation.
		
		What version of Saxon are you using ?
		

I am using the last recomended version in the site: 6.5.3. May try the newer versions.
Still, we use Saxon for part of our build process, and use Xalan for other aspects of our
work.
I really think we need to be able to control better what is going on.
 
 
Jose Alberto
 

 
Mime
View raw message