ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colin Sampaleanu <colin...@exis.com>
Subject Did 1.6 break old filter behaviour?
Date Tue, 06 Jan 2004 17:23:17 GMT
I have a filter set as follows:

<property name="email.from" value="admin-dev@something.com"/>
...
<filter token="EMAIL_FROM" value="${email.from}" />

this worked fine in ant 1.5, for replacing this filter value in a file 
with multiple @EMAIL_FROM@ tokens in it, via a copy task with filter="on"

With ant 1.6, I now get this behaviour:
     [copy] Copying 1 file to 
D:\src\something\cvs\core\core-services\target\classes
     [copy] Replacing: @EMAIL_FROM@ -> admin-dev@something.com
     [copy] Inifinite loop in tokens. Currently known tokens : [EMAIL_FROM]
     [copy] Problem token : @EMAIL_FROM@ called from @EMAIL_FROM@
     [copy] Replacing: @EMAIL_FROM@ -> EMAIL_FROM
     [copy] Replacing: @EMAIL_FROM@ -> EMAIL_FROM
     [copy] Replacing: @EMAIL_FROM@ -> EMAIL_FROM
     [copy] Replacing: @EMAIL_FROM@ -> EMAIL_FROM
     [copy] Replacing: @EMAIL_FROM@ -> EMAIL_FROM
     [copy] Replacing: @EMAIL_FROM@ -> EMAIL_FROM
     ... and so on

Now obviously the @ sign in the email address is confusing the token 
processor, and it works fine if I replace it with another value, but 
this worked fine in ant 1.5!

Can anybody confirm if this is a bug?



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message