ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 25868] New: - JAVAC debug=off attribute is inconsistent among jikes and javac compiler
Date Fri, 02 Jan 2004 19:29:33 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25868>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25868

JAVAC debug=off attribute is inconsistent among jikes and javac compiler

           Summary: JAVAC debug=off attribute is inconsistent among jikes
                    and javac compiler
           Product: Ant
           Version: 1.6.0
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Minor
          Priority: Other
         Component: Core tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: jslopez@forumsys.com


In order to see the problem you are probably going to need a decompiler I was 
using jad. The command I was running is jad -p -lnc Test.class
So this is the behavior am seeing:
ant compile -> jad shows no line numbers.
ant jikes compile -> jad shows line numbers

javac Test.class -> jad shows line numbers
jikes -classpath $JAVA_HOME/jre/lib/rt.jar Test.class -> jad shows line numbers

So the problem is as follows by default javac and jikes add the debugging
information to the class files. In order to disable the functionality the
-g:none flags needs to be passed. Ant does this automatically for javac but not
for jikes. Attached is a patch to Jikes.java that will
make the behavior consistent.

jdk 1.4.1_02
ant 1.6.0
jad 1.5.8e

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message