ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 25595] New: - ant.bat on Windows 2000 displays java usage statement
Date Wed, 17 Dec 2003 16:56:05 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25595>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25595

ant.bat on Windows 2000 displays java usage statement

           Summary: ant.bat on Windows 2000 displays java usage statement
           Product: Ant
           Version: 1.5.4
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Wrapper scripts
        AssignedTo: dev@ant.apache.org
        ReportedBy: andyjohnson@engineer.com


java/jvm is 1.4.2_03 running on Windows 2000.

After installing ant 1.5.4, running ant from the command line produces the java 
usage statement.  Modified ant.bat to get ant to work.

On the offending machine, the following ant.bat line generates the usage 
statement: 
"%_JAVACMD%" %ANT_OPTS% -classpath "%LOCALCLASSPATH%" "-Dant.home=%ANT_HOME%" 
org.apache.tools.ant.Main %ANT_ARGS% %ANT_CMD_LINE_ARGS%

Modified the line to be the following and problem solved (removed double quotes 
from around the -D java option):
"%_JAVACMD%" %ANT_OPTS% -classpath "%LOCALCLASSPATH%" -Dant.home=%ANT_HOME% 
org.apache.tools.ant.Main %ANT_ARGS% %ANT_CMD_LINE_ARGS%

Is this the wrong place to post this error?  My apologies in advanced if so.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message