ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 25398] New: - macrodef broken: attribute values aren't being set
Date Wed, 10 Dec 2003 13:53:08 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25398>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25398

macrodef broken: attribute values aren't being set

           Summary: macrodef broken: attribute values aren't being set
           Product: Ant
           Version: 1.6Beta
          Platform: PC
        OS/Version: Other
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Core tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: jmlennon@us.ibm.com


[ I'm sure someone has already pointed out this problem, but I couldn't
  find a defect report when I queried bugzilla, so here's mine. ]

The macrodef task doesn't work because attribute values (both default
values and passed in values) are not getting set.  This worked in
1.6beta2, but seems to be broken in 1.6beta3.  Here's a build file
that demonstrates the problem:

===============================================
<?xml version="1.0"?>

<project name="macrodef-bug" default="show-bug">

  <macrodef name="my-macro">
    <attribute name="arg1"/>
    <attribute name="arg2" default="arg2-default-value"/>
    <sequential>
      <echo message="Macrodef arg1 value: ${arg1}"/>
      <echo message="Macrodef arg2 value: ${arg2}"/>
    </sequential>
  </macrodef>

  <target name="show-bug">
    <my-macro arg1="my-arg1-value"/>
  </target>

</project>
=========================================

And here's what happens when you run Ant.  As you can see,
the macrodef argument values are not getting set.

H:\temp>ant -version
Apache Ant version 1.6beta3 compiled on December 5 2003
H:\temp>ant
Buildfile: build.xml

show-bug:
     [echo] Macrodef arg1 value: ${arg1}
     [echo] Macrodef arg2 value: ${arg2}

BUILD SUCCESSFUL
Total time: 0 seconds

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message