ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 25211] New: - ant ftp task does not use ascii transfer to send files to host with Suse Linux 9.0
Date Thu, 04 Dec 2003 17:10:02 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25211>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25211

ant ftp task does not use ascii transfer to send files to host with Suse Linux 9.0

           Summary: ant ftp task does not use ascii transfer to send files
                    to host with Suse Linux 9.0
           Product: Ant
           Version: 1.5.4
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Other
        AssignedTo: dev@ant.apache.org
        ReportedBy: burkhard.mahr@softlab.de


Even my ant script defines binary option to "no" the transfer of files
from W2000 to Suse Linux is binary instead of ASCII.

I use the following Ant script:
roject name="template" default="ftp.generic" basedir=".">
  <target name="ftp.generic">
	<echo message="Deploying Test"/>

	<!-- put ascii files -->
	<echo>transferring ascii files ... </echo>
  	<ftp server="pc5075" userid="qqtemplate" password="xbmw" 
  		remotedir="/www/template/config/template_deploy"
  		action="put"  
  		verbose="yes"
  		binary="no">
		<fileset dir=".">
			<!-- include ascii files -->
			<include name="prepa*"/>
		</fileset>  
	</ftp>

  </target>
</project>


The output is:

ftp.generic:
     [echo] Deploying Test
     [echo] transferring ascii files ...
      [ftp] Opening FTP connection to pc5075
      [ftp] connected
      [ftp] logging in to FTP server
      [ftp] login succeeded
      [ftp] changing the remote directory
      [ftp] sending files
fileset: Setup scanner in dir D:\unix_deploy with patternSet{ includes: 
[prepa*] excludes: [] }
      [ftp] transferring D:\unix_deploy\prepare_installation
      [ftp] File D:\unix_deploy\prepare_installation copied to pc5075
      [ftp] 1 files sent
      [ftp] disconnecting
The file should be ascii transfered but it is transferred binary.

 If I do manually transfer with windows ftp client in ascii mode the transfer 
works fine. Any hints?

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message