ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 24481] New: - ModifiedSelectorTest fails due to relative ant.home when run by build.sh
Date Thu, 06 Nov 2003 22:48:56 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=24481>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=24481

ModifiedSelectorTest fails due to relative ant.home when run by build.sh

           Summary: ModifiedSelectorTest fails due to relative ant.home when
                    run by build.sh
           Product: Ant
           Version: 1.7Alpha (nightly)
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Build Process
        AssignedTo: dev@ant.apache.org
        ReportedBy: f.g.haas@gmx.net


When running "build.sh test" on Linux (and presumably any other *nix), the test
org.apache.tools.ant.types.selectors.ModifiedSelectorTest fails with the
following output:

Testcase:
testScenarioCustomSelectorSettings(org.apache.tools.ant.types.selectors.ModifiedSelectorTest):
       Caused an ERROR
/home/fgh/workspace/ant/src/etc/testcases/types/bootstrap/lib not found.
/home/fgh/workspace/ant/src/etc/testcases/types/selectors.xml:132:
/home/fgh/workspace/ant/src/etc/testcases/types/bootstrap/lib not found.
        at
org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileSet.java:387)
        at org.apache.tools.ant.taskdefs.Copy.execute(Copy.java:438)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:302)
        at org.apache.tools.ant.Task.perform(Task.java:401)
        at org.apache.tools.ant.Target.execute(Target.java:338)
[...]

At this point (line 132 in src/etc/testcases/types/selectors.xml) the build file
is using the ant.home property. The build.sh script sets the ANT_HOME envar to
just "bootstrap". The test, when run interprets this relative to the build file
directory (hence, src/etc/testcases/types/bootstrap), causing the test to fail
since that directory does not exist.

The issue can be easily fixed by having build.sh set ANT_HOME to an absolute
path. For bash, ANT_HOME=$PWD/bootstrap should do.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message