ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Abey Mullassery" <a...@mullassery.com>
Subject RE: New ANT Image Transformation Tasks
Date Thu, 09 Oct 2003 17:48:21 GMT
>
> You patch says compatible with Ant 1.3 while your website says 1.4.
>

Sorry for the mistake.
The Task works with Ant version 1.4 onwards only. Could you please change
it?


The Task uses an image core library that has the implementations for using
ImageIO, AWT, JAI, etc. The required implementation is loaded at runtime
based on which of these imaging libraries are available.

Since ImageIO requires Java 1.4, I have to compile it with j2sdk-1.4 or
higher. But this would make the jar unusable to others who are using this
task with j2sdk-1.2 or j2sdk-1.3.

Hence I compiled the ImageIO implementation with j2sdk-1.4 (anyway it is
available at runtime only if you are using j2sdk-1.4) and the rest of the
classes with j2sdk-1.3. Thus the classes meant for use with other JREs < 1.4
will also work.

Is there a better way of getting the same effect?

Thanks,


Abey Mullassery
W: http://www.mullassery.com
==============================


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message