ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Albrecht, Matt" <matt.albre...@zilliant.com>
Subject RE: Ant 1.6beta1 comments
Date Thu, 02 Oct 2003 15:28:30 GMT
I should probably open a Bugzilla bug on this, but I'll go ahead and post it
here to see everyone's opinion.

Here's the situation:

File testbug1.xml:
<project name="TestBug" default="main">
    
    <property name="main-target" value="main" />
    <property name="main-file" value="testbug2.xml" />
    
    <target name="main" >
        <ant target="${main-target}" antfile="${main-file}" />
    </target>
</project>

File testbug2.xml:
<project name="testBug2" default="main">
    <target name="main">
        <style style="mystyle.xsl" basedir="${basedir}"
            destdir="${basedir}" extension=".html">
            <include name="convert.xml" />
        </style>
    </target>
</project>

(assuming "mystyle.xml" and "convert.xml" exist as well).

Running on Windows XP, and Sun JDK 1.2.2_015, and without Xalan in the
classpath, I correctly get an error that the Transformer could not be found.
However, the error looks like:

C:\test\testbug1.xml:10:
javax.xml.transform.TransformerFactoryConfigurationError: Provider for
javax.xml.transform.TransformerFactory cannot be found

It incorrectly shows the error location as being in testbug1.xml, not
testbug2.xml.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message