ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 24016] New: - Copy task does not copy empty directories
Date Wed, 22 Oct 2003 20:09:02 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=24016>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=24016

Copy task does not copy empty directories

           Summary: Copy task does not copy empty directories
           Product: Ant
           Version: 1.6Beta
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Core tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: bpracht@zcloud.net


The Ant copy task doesn't copy empty subdirectories, despite regardless of the 
value of the includeEmptyDirs attribute.  Here's a test build file.

<?xml version="1.0"?>
<project name="CopyTest" default="copyTest" basedir=".">
    <target name="copyTest" depends="">
        <mkdir dir="target"/>
        <mkdir dir="source"/>
        <mkdir dir="source/empty"/>
        <echo file="source/readme.txt">
            Copying Empty Directories doesn't Work
        </echo>
        <copy todir="target" overwrite="false" verbose="true" flatten="false" 
includeEmptyDirs="true">
            <fileset dir="source" includes="**/*.*"/>
        </copy>
    </target>
</project>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message