ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 23785] New: - [patch] Having <uptodate> execute a nested <sequential> if the target is out of date
Date Mon, 13 Oct 2003 16:05:30 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=23785>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=23785

[patch] Having <uptodate> execute a nested <sequential> if the target is out of
date

           Summary: [patch] Having <uptodate> execute a nested <sequential>
                    if the target is out of date
           Product: Ant
           Version: 1.7Alpha (nightly)
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Enhancement
          Priority: Other
         Component: Core tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: pdmclach1@msn.com


Basically, I've added the capability for <uptodate> to have a nested
<sequential> task that only gets executed if the targets are out of date.  At
present I have to create a whole other <target> to do the dependency check so
that the primary target and have an unless="blah.uptodate".

This would make my ant script have fewer 'unnecessary' targets & seems like a
good idea.  (To me, anyway).

Apprently ant-contrib has this already.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message