ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Cohen" <SCo...@sportvision.com>
Subject RE: can't build ant 1.6
Date Mon, 01 Sep 2003 20:22:23 GMT
I tried both with and without separate ./boostrap.sh commands, but I did not
build the way you suggest.  My commands were

./bootstrap.sh
./build.sh -Ddist.dir=dist dist-lite

This used to work but no longer does.

If there is a change to the recommended way of building Ant, methinks that should be well-documented
somewhere.



-----Original Message-----
From:	Antoine Levy-Lambert [mailto:antoine@antbuild.com]
Sent:	Mon 9/1/2003 3:01 PM
To:	Ant Developers List
Cc:	
Subject:	Re: can't build ant 1.6
Hi Steve,

what I am doing to build ant 1.6 is :

./bootstrap.sh
./build.sh install-lite
ant -D"test.haltonfailure=no" test

this sequence works for me.

Maybe you get hit if you do not first run bootstrap.sh separately.

There have been some changes involving copying xml-apis.jar and Xerces.jar
from lib to bootstrap/lib when building or bootstrapping ant, and removing
xml-apis.jar and Xerces.jar from the CLASSPATH of build.sh.

Hopes this helps,

Antoine


----- Original Message -----
From: "Steve Cohen" <SCohen@sportvision.com>
To: "Steve Cohen" <SCohen@sportvision.com>; <ant-dev@jakarta.apache.org>
Sent: Monday, September 01, 2003 7:14 PM
Subject: RE: can't build ant 1.6


I've received no replies to this, so let me try again with a little more
information.  Previous versions of build.sh (or build.bat)  contained this
sequence:

LOCALCLASSPATH=lib/xercesImpl.jar:lib/xml-apis.jar:bootstrap/lib/ant.jar
# add in the dependency .jar files
DIRLIBS=lib/optional/*.jar
for i in ${DIRLIBS}
do
    if [ "$i" != "${DIRLIBS}" ] ; then
        LOCALCLASSPATH=$LOCALCLASSPATH:"$i"
    fi
done

In the current version, it is like this:

LOCALCLASSPATH=
# add in the dependency .jar files
DIRLIBS=lib/optional/*.jar
for i in ${DIRLIBS}
do
    if [ "$i" != "${DIRLIBS}" ] ; then
        LOCALCLASSPATH=$LOCALCLASSPATH:"$i"
    fi
done

The difference is that LOCALCLASSPATH is no longer being preset with
xercesImpl.jar and xml-apis.jar before the optional directory is scanned.
The absence of these jars from the classpath was what led to the failures
below.  Getting them onto the classpath solved the problem.

But is this a bug?  Or is it an undocumented requirement that ant be built
in an environment that has these or other such jars on the classpath?  Or is
it a documented requirement and I've just been unable to find the
documentation?

-----Original Message-----
From: Steve Cohen
Sent: Sat 8/30/2003 5:09 PM
To: ant-dev@jakarta.apache.org
Cc:
Subject: can't build.
This is my first attempt to build ant in awhile.

I downloaded a completely fresh source tree from cvs, made a couple of
extremely minor changes, and then tried to build with build.sh.  The
bootstrap build successfully completes, but then when the main build starts,
I get this:

[scohen@sleepingbear ~/ant]$ ./build.sh -Ddist.dir=dist dist
ANT_HOME=bootstrap
Buildfile: build.xml

BUILD FAILED
XML parser factory has not been configured correctly:
java.lang.ClassNotFoundException:
org.apache.xerces.jaxp.SAXParserFactoryImpl

I don't understand this.

My ant/lib directory contains (from the download)

     927669   8-01-2003   1:45a -rw-rw-r--
/home/scohen/ant/lib/xercesImpl.jar
     108484   6-01-2002   7:26a -rw-rw-r--
/home/scohen/ant/lib/xml-apis.jar

What am I missing?  I've never needed anything else to build ant.  Has
something changed in the build procedure?




---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org






Mime
View raw message