ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Mclachlan <>
Subject Re: [patch] Having <uptodate> execute a nested <sequential> if the target is out of date
Date Sat, 20 Sep 2003 00:32:39 GMT
Martijn Kruithof wrote:

> If you make something like this (I don't see a direct benefit), why 
> not make uptodate an taskcontainer so that you can wrap any task in 
> there without the need of indirection via the sequential task.

But if you make <uptodate> a task container itself, it couldn't have 
nested elements that *weren't* tasks (such as it's existing feature of 
nested <srcfiles> or nested <mapper>).  Right?  Or maybe I'm missing 
something.  But (even if I was) it seems like if you adopt this approach 
in general (and make it work), you could have problems with a task name 
conflicting with the name of a normally nested element.

I think it's much better to use a nested <sequential>.  It wouldn't have 
to be called "sequential", of course, we could call it something else, 
like "runIfOutOfDate", but <sequential> seemed more fitting (since 
people will - presumably - already know what it does & what it should 

- Paul

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message