ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Loughran <stev...@iseran.com>
Subject Re: exec cp won't work -- cannot stat existing file
Date Thu, 28 Aug 2003 19:08:22 GMT
Ben Pracht wrote:
> Because the copy task won't copy symlinks on Linux, I'm using an exec 
> task.  Unfortunately, it keeps giving me this message:
> 
>     [exec] Current OS is Linux
>     [exec] Executing 'cp' with arguments:
>     [exec] 
> '/home/bpracht/xks/current/internal/debug/Linux/2.4.18-14debug/i386/xml4c/lib/*' 
> 
>     [exec] 
> '/home/bpracht/xks/current/install/debug/Linux/2.4.18-14debug/i386'
>     [exec]
>     [exec] The ' characters around the executable and arguments are
>     [exec] not part of the command.
>     [exec] /bin/cp: cannot stat 
> `/home/bpracht/xks/current/internal/debug/Linux/2.4.18-14debug/i386/xml4c/lib/*': 
> No such file or directory
> 
> Both the source and target exist.

um, unless you have a source file of the name '*', it doesnt exist 
-there is no shell under exec to do the expansion unless you exec sh or 
similar

>       <exec executable="${CopyCommand}"
>             dir="${internal}"
>             vmlauncher="true"
>             failonerror="true">
>          <arg path="${internal}/xml4c/lib/*"/>
>          <arg path="${install}/."/>
>       </exec>



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message