ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 22705] - ant 1.6alpha (and possibly earlier) requires JDK 1.4
Date Mon, 25 Aug 2003 22:57:36 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22705>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22705

ant 1.6alpha (and possibly earlier) requires JDK 1.4





------- Additional Comments From ccorsi@exln.com  2003-08-25 22:57 -------
I have seen this problem before. The StringBuffer.append(StringBuffer) method was
added in jdk 1.4. If someone will build a distribution that tries to append a
StringBuffer to a StringBuffer with jdk prior to 1.4. The build will succeed and
it will run correctly. If you build it with jdk 1.4, it will use the new
StringBuffer.append(StringBuffer) method and not the StringBuffer.append(Object)
method. 

That said, you are probably using an ant 1.6-alpha version that has been built
using jdk 1.4. You should then build the ant 1.6-alpha distribution with jdk 1.2
or 1.3 and this problem will go away.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message